[xcode]Could not locate device support files.

■追記 2016/10/27 からAppStoreでもダウンロードしてアップデートできるようになったようです。
=====
2016/10/26 AM2:00時点での状況です。
iOS10.1のリリース時間は2016/10/25 AM2:00あたりです。
■現象まとめ
使用しているiPhone7のiOSを10.1にアップデート
自作アプリ(ストアリリースはしていないもの)を起動しようとしたら落ちる
xcodeでビルドしようとしたところ、以下のエラーが発生

Could not locate device support files.
This iPhone 7 (Model 1660, 1778, 1779, 1780) is running iOS 10.1 (14B72c), which may not be supported by this version of Xcode.

→要は、Xcodeのバージョンが古くて、そのiOSはサポートされていませんという話。
 大抵は、機種変などでiOSバージョンアップにともない、Xcodeが対応できていない状態になったことで発生するかと思います。
■確認したこと
・MacでApp Storeを起動しxcodeで検索したところアップデートはない(バージョン8.0が最新と表示されました)
・xcodeの上部メニューからXcode->About Xcodeでバージョン確認したところ、Version 8.0 (8A218a)
・devのサイトで確認 → Xcode 8.1 GM seed というバージョンを確認
https://developer.apple.com/download/
どうやらdevサイトからダウンロードして、Xcodeをアップデートしないと行けない模様
ダウンロードしたxcodeでビルド、アプリインストールを行うと無事に動くようになりました。
ただ、念のため、Xcodeの上書きインストールは行っていません。
■補足
ダウンロードしたところ、xip形式でした。
 ※macからは、zipのように扱えます。
xip拡張子についてのメモ

シェアする

  • このエントリーをはてなブックマークに追加

フォローする