railsインストールエラーとrubyバージョンアップ

以下のコマンドでrailsをインストールしようとしたところエラーになりました

# gem install rails
ERROR:  Error installing rails:
	activesupport requires Ruby version >= 2.2.2.

まずは、バージョンを確かめた

$ ruby -v
ruby 2.0.0p648 (2015-12-16 revision 53162) [universal.x86_64-darwin15]

確かにバージョンが古い。

ということで、バージョンをアップしました。

■手順
現在インストールすることができるRubyの一覧を表示、インストールするバージョンを選ぶ

$ rbenv install -l

インストール

$ rbenv install 2.2.2

標準で使うのバージョンを設定

$ rbenv global 2.2.2

インストールできているか確認

$ ruby -v

参考

a

スポンサーリンク







シェアする

  • このエントリーをはてなブックマークに追加

フォローする

スポンサーリンク