[Windows]Cygwin環境作成

細かな設定が必要

  1. Cygwinのダウンロード&インストール
    https://www.cygwin.com/ にアクセス

    • Install Cygwin を選択
    • setup-x86_64.exe をダウンロード
      (64-bit versions of Windowsなので、32bitのPCならsetup-x86.exeとか)
    • setup-x86_64.exe を実行
      インストールするパッケージは、searchしながら選んでいく。
      もしくは、apt-cyg install パッケージ名で、個別にインストールしていく
      何を入れたかは忘れたので、調べてみた。

      $ cygcheck -c
      Cygwin Package Information
      Package              Version            Status
      _autorebase          001004-1           OK
      _update-info-dir     03000-1            OK
      alternatives         1.3.30c-10         OK
      base-cygwin          3.8-1              OK
      base-files           4.2-4              OK
      bash                 4.3.42-4           OK
      busybox              1.23.2-1           OK
      bzip2                1.0.6-2            OK
      ca-certificates      2.7-1              OK
      coreutils            8.25-3             OK
      crypt                1.3-1              OK
      csih                 0.9.9-1            OK
      curl                 7.48.0-1           OK
      cygrunsrv            1.62-1             OK
      cygutils             1.4.15-2           OK
      cygwin               2.5.1-1            OK
      dash                 0.5.8-3            OK
      diffutils            3.3-3              OK
      editrights           1.03-1             OK
      file                 5.25-1             OK
      findutils            4.6.0-1            OK
      gawk                 4.1.3-1            OK
      getent               2.18.90-4          OK
      grep                 2.24-1             OK
      groff                1.22.3-1           OK
      gzip                 1.7-2              OK
      hostname             3.13-1             OK
      info                 6.1-2              OK
      ipc-utils            1.0-2              OK
      less                 481-1              OK
      libapr1              1.5.2-2            OK
      libaprutil1          1.5.4-2            OK
      libargp              20110921-2         OK
      libattr1             2.4.46-1           OK
      libblkid1            2.25.2-2           OK
      libbz2_1             1.0.6-2            OK
      libcatgets1          1.1-2              OK
      libcom_err2          1.42.12-2          OK
      libcrypt0            1.3-1              OK
      libcurl4             7.48.0-1           OK
      libdb5.3             5.3.21-1           OK
      libedit0             20130712-1         OK
      libexpat1            2.1.1-1            OK
      libffi6              3.2.1-2            OK
      libgcc1              5.3.0-5            OK
      libgdbm4             1.11-1             OK
      libgmp10             6.1.0-3p1          OK
      libgnutls28          3.3.17-1           OK
      libgssapi_krb5_2     1.14.1-1           OK
      libhogweed2          2.7.1-1            OK
      libiconv             1.14-3             OK
      libiconv2            1.14-3             OK
      libidn11             1.29-1             OK
      libintl8             0.19.7-1           OK
      libiodbc2            3.52.8-2           OK
      libk5crypto3         1.14.1-1           OK
      libkrb5_3            1.14.1-1           OK
      libkrb5support0      1.14.1-1           OK
      liblzma5             5.2.2-1            OK
      libmetalink3         0.1.2-1            OK
      libmpfr4             3.1.4-1            OK
      libmysqlclient18     5.5.45-1           OK
      libncursesw10        6.0-5.20160423     OK
      libneon27            0.30.1-1           OK
      libnettle4           2.7.1-1            OK
      libnghttp2_14        1.7.1-1            OK
      libopenldap2_4_2     2.4.42-1           OK
      libopenssl100        1.0.2h-1           OK
      libp11-kit0          0.22.1-1           OK
      libpcre1             8.38-3             OK
      libpipeline1         1.4.0-1            OK
      libpopt0             1.16-1             OK
      libpq5               9.5.2-1            OK
      libproxy1            0.4.11-5           OK
      libpsl5              0.13.0-1           OK
      libreadline7         6.3.8-1            OK
      libsasl2_3           2.1.26-9           OK
      libserf1_0           1.3.8-1            OK
      libsigsegv2          2.10-2             OK
      libsmartcols1        2.25.2-2           OK
      libsqlite3_0         3.12.2-1           OK
      libssh2_1            1.7.0-1            OK
      libssp0              5.3.0-5            OK
      libstdc++6           5.3.0-5            OK
      libtasn1_6           4.7-1              OK
      libunistring2        0.9.6-1            OK
      libuuid1             2.25.2-2           OK
      login                1.11-1             OK
      lynx                 2.8.7-2            OK
      man-db               2.7.4-1            OK
      man-pages-posix      2013-a-1           OK
      manlint              1.6g-2             OK
      md5deep              4.4-1              OK
      mintty               2.3.6-0            OK
      ncurses              6.0-5.20160423     OK
      openssh              7.2p2-1            OK
      openssl              1.0.2h-1           OK
      p11-kit              0.22.1-1           OK
      p11-kit-trust        0.22.1-1           OK
      patch                2.7.4-1            OK
      perl                 5.22.2-1           OK
      perl_autorebase      5.22.2-1           OK
      perl_base            5.22.2-1           OK
      popt                 1.16-1             OK
      rebase               4.4.2-1            OK
      run                  1.3.4-2            OK
      sed                  4.2.2-3            OK
      subversion           1.9.4-1            OK
      tar                  1.28-1             OK
      tcsh                 6.19.00-2          OK
      terminfo             6.0-5.20160423     OK
      tzcode               2016d-1            OK
      tzdata               2016d-1            OK
      unzip                6.0-15             OK
      util-linux           2.25.2-2           OK
      vim                  7.4.1816-1         OK
      vim-common           7.4.1816-1         OK
      vim-minimal          7.4.1816-1         OK
      wget                 1.17.1-2           OK
      which                2.20-2             OK
      xxd                  7.4.1816-1         OK
      xz                   5.2.2-1            OK
      zlib0                1.2.8-3            OK

コメント

タイトルとURLをコピーしました